Differences

This shows you the differences between the selected revision and the current version of the page.

at:download 2007/07/28 17:16 at:download 2020/02/10 13:59 current
Line 1: Line 1:
~~NOTOC~~ ~~NOTOC~~
====== Downloading/Installing AmbientTalk ====== ====== Downloading/Installing AmbientTalk ======
 +
===== AmbientTalk/2 ===== ===== AmbientTalk/2 =====
Line 8: Line 9:
AmbientTalk/2 has been designed to co-exist with available Java programs. It offers a symbiotic interface to the Java language, making it possible to instantiate and use Java objects from within AmbientTalk, and to pass AmbientTalk objects that implement a Java interface to the Java level. This makes AmbientTalk an ideal language to write 'distributed glue code' to make isolated Java programs talk to one another. AmbientTalk/2 has been designed to co-exist with available Java programs. It offers a symbiotic interface to the Java language, making it possible to instantiate and use Java objects from within AmbientTalk, and to pass AmbientTalk objects that implement a Java interface to the Java level. This makes AmbientTalk an ideal language to write 'distributed glue code' to make isolated Java programs talk to one another.
-== Download ==+To get started with AmbientTalk programming, we recommend installing our Intellij IDEA plugin (see IDE support).
-<note tip>Download the [[http://prog.vub.ac.be/amop/downloads/at2-build270707.zip|latest build]] (AmbientTalk 2.6)+<box 80% round blue><html><center style="clear:both;"><img src="http://soft.vub.ac.be/amop/_media/at/intellij_idea.png" style="vertical-align:middle" height="50px"/><font size="+1"><a href=""https://plugins.jetbrains.com/plugin/8884-ambienttalk-ide">Install Intellij IDEA Plugin 
-</note>+</a></font> </html></box>
-See the [[at:changelog|changelog]] for changes w.r.t. previous versions. 
-This build contains: 
-  * The AmbientTalk/2 Interpreter (about 500K) 
-  * The IAT Interactive AmbientTalk Shell 
-  * The system library 
-  * Additional libraries (ANTLR,GetOpt) used by the interpreter (about 500K) 
-  * The TextMate plugin (see below) 
-== Requirements == 
-The AmbientTalk/2 interpreter is written in pure Java and requires a regular J2SE Java Virtual Machine supporting version 1.3 or higher. AmbientTalk can be run under the Java 2 Micro Edition (J2ME) CDC/Personal Profile. This allows AT/2 to run on PDAs and high-end cellular phones. A build for J2ME CLDC is currently not available.+==== Download the AmbientTalk Distribution ==== 
 + 
 +If you are interested in downloading a stand-alone version of the AmbientTalk/2 interpreter and run it via command line: 
 + 
 +<box 80% round blue><html><center style="clear:both;"><font size="+1"><a href="https://drive.google.com/drive/folders/0B07Ew8FJun94MVJrTHlBWlJfeFE">Download AmbientTalk 2.23  
 +</a></font> </html></box> 
 + 
 +See the [[https://gitlab.soft.vub.ac.be/ambienttalk/ambienttalk/wikis/Change-Log|changelog]] for changes w.r.t. previous versions. 
 + 
 +This build contains: 
 +  * The AmbientTalk/2 Interpreter 
 +  * iat, the Interactive AmbientTalk Shell 
 +  * The AmbientTalk standard library
== Installation and Usage == == Installation and Usage ==
Line 37: Line 42:
<note tip>We advise you to add ''iat'' to the ''$PATH'' environment variable, such that ''iat'' can be invoked from any directory. Note also that ''iat'' assumes that the ''java'' executable is available on the ''$PATH''</note> <note tip>We advise you to add ''iat'' to the ''$PATH'' environment variable, such that ''iat'' can be invoked from any directory. Note also that ''iat'' assumes that the ''java'' executable is available on the ''$PATH''</note>
-== TextMate Plugin ==+<note warning> 
 +**Note to windows users:** ''iat.bat'' has been reported not to work when the ''AT_HOME'' directory contains spaces, so consider placing your AmbientTalk distribution in a directory that does not contain spaces. 
 +</note>
-Support for AmbientTalk is available in the form of a [[http://www.macromates.com|TextMate]] bundle for AmbientTalk/2, which is available in the latest build.+<note warning> 
 +For service discovery, AmbientTalk makes use of IP multicasting. AmbientTalk broadcasts messages to IP 224.0.0.1 on port 4446. Make sure your firewall does not block this port. 
 +</note> 
 + 
 +== Requirements == 
 + 
 +The AmbientTalk/2 interpreter is written in pure Java and requires a regular J2SE Java Virtual Machine supporting version 1.5 or higher. AmbientTalk currently runs on Android version 1.6 or higher, and on J2ME under a CDC/Personal Profile configuration. 
 + 
 +<box 80% round blue><html><center><font size="+1"><div><a  href="https://market.android.com/details?id=edu.vub.at.android.interpreter">Download AmbientTalk for  
 +<br /></div></a></font> <a href="https://market.android.com/details?id=edu.vub.at.android.interpreter"> <img src="http://soft.vub.ac.be/amop/_media/at/androidlogo.png" height="90px" style="vertical-align:middle" /></a></center></html></box> 
 + 
 +[[at:amophtc|Additional instructions]] on how to run AmbientTalk on J2ME. 
 + 
 + 
 + 
 + 
 +==== IDE Support ==== 
 + 
 +We recommend using our Intellij IDEA plugin which already contains the AmbientTalk/2 interpreter and the AmbientTalk standard library (atlib). 
 + 
 +<box 70% round orange><html><center><img src="http://soft.vub.ac.be/amop/_media/at/intellij_idea.png" style="vertical-align:middle" height="90px"/><font size="+1"><a style="margin-left: 1em" href="https://plugins.jetbrains.com/plugin/8884-ambienttalk-ide">Install Intellij Plugin</a></font></center></html></box> 
 + 
 + 
 +For Mac OS X users that use TextMate, there exists a [[http://www.macromates.com|TextMate]] bundle for AmbientTalk/2, which is available for download below.
The TextMate plugin supports: The TextMate plugin supports:
Line 45: Line 75:
  * Autocompletion for statements such as ''if'', ''def'' etc. (by pressing TAB)   * Autocompletion for statements such as ''if'', ''def'' etc. (by pressing TAB)
  * Running AmbientTalk/2 scripts by pressing Apple+R (output is shown in a separate window)   * Running AmbientTalk/2 scripts by pressing Apple+R (output is shown in a separate window)
 +
 +<box 70% round orange><html><center><font size="+1"><a href="http://soft.vub.ac.be/amop/downloads/at2textmate.zip">Download TextMate Plugin</a></font></center></html></box>
<html><font color="red">Please note:</font></html> upon installing the bundle, you need to set the ''AT_HOME'' variable in the TextMate Preferences window (under the Advanced tab pane) to point to the directory in which iat can be found. <html><font color="red">Please note:</font></html> upon installing the bundle, you need to set the ''AT_HOME'' variable in the TextMate Preferences window (under the Advanced tab pane) to point to the directory in which iat can be found.
Line 50: Line 82:
For a full overview of the supported features, open the Bundles > Bundle Editor > Show Bundle Editor menu and select the AmbientTalk 2 bundle in the bundle editor. All available actions, together with their hotkey are listed there. For a full overview of the supported features, open the Bundles > Bundle Editor > Show Bundle Editor menu and select the AmbientTalk 2 bundle in the bundle editor. All available actions, together with their hotkey are listed there.
-== Documentation ==+==== Documentation ====
See the [[at:tutorial:tutorial|tutorial]] for an introduction to AmbientTalk/2. An overview of the available primitives and libraries is available in the [[at:reference:reference|language reference]]. See the [[at:tutorial:tutorial|tutorial]] for an introduction to AmbientTalk/2. An overview of the available primitives and libraries is available in the [[at:reference:reference|language reference]].
 
 
 
Recent changes RSS feed Creative Commons License Donate Powered by PHP Valid XHTML 1.0 Valid CSS Driven by DokuWiki